Guvnor 5.3.0 on Jboss-as-7 deployment

Standard
Spread the love

Thought of getting more familiar with JBoss Drools and its web based Guvnor interface, so I downloaded Guvnor 5.3.0 (approx 360mb package) from Jboss.org. After opening the zip file, I found there are 4 war files available for getting started with Guvnor interface. The files are for following server
1. Tomcat 6
2. Jboss 5
3. Jboss 6
4. Jboss 7
I selected Jboss 7 version war file and tried to deploy on Jboss 7.0.2 Final server. Pufff… it just failed silently and gave error

18:55:33,061 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) Did not receive a response to the deployment operation within the allowed timeout period [60 seconds]. Check the server configurationfile and the server logs to find more about the status of the deployment.


The error message doesn’t signify as what went wrong with WAR deployment and the log file unfortunately doesn’t have any details either, almost Clueless…
After bit googling around the web, I found quite a few posts suggesting to increasing deployment-timeout in standalone.xml file. So I changed the settings inside JBOSS_DIR/standlone/configuration/standalone.xml and it worked. 🙂
If anyone interested, you can go through following steps.
1. Locate standalone.xml as specified above.
2. Search for

..

3. Add attribute

deployment-timeout="600"

to “deployment-scanner” element.

Hope this helps!

8 thoughts on “Guvnor 5.3.0 on Jboss-as-7 deployment

  1. Karthik J

    Even i made the same fix. It was working fine for 600 seconds, but again deployment of my ear failed with the same error. Any insight where exactly may be the problem??

Leave a Reply

Your email address will not be published. Required fields are marked *